const regex = /\s\S+\.com\s/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s\\S+\\.com\\s', 'gm')
const str = `текст текст site.com текст
`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);