package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^S.*, [^S].*$`)
var str = `Schmidt, Paul
Sells, Simon
Smith, Peter
Stephens, Sheila`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}