const regex = /\(define-fun\s+(\S+).*\n\s*(\d+)\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\(define-fun\\s+(\\S+).*\\n\\s*(\\d+)\\)', 'gm')
const str = ` (define-fun X_1 () Int
281)
(define-fun X_71 () Int
104)
(define-fun X_90 () Int
21)
(define-fun X_54 () Int
250)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}