#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?P<x>\w*?)(?P<y>\d*)$"
Local $sString = "df" & @CRLF & _
" Ref" & @CRLF & _
"0 CU12" & @CRLF & _
"1 SE00" & @CRLF & _
"2 RLA1234" & @CRLF & _
"3 12345" & @CRLF & _
"3 RLA456" & @CRLF & _
"4 LU00" & @CRLF & _
"5 RLA1234MA12" & @CRLF & _
"6 RLA1234MA13" & @CRLF & _
"7 CU00" & @CRLF & _
"8 LU00"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")