using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<x>\w*?)(?P<y>\d*)$";
string input = @"df
Ref
0 CU12
1 SE00
2 RLA1234
3 12345
3 RLA456
4 LU00
5 RLA1234MA12
6 RLA1234MA13
7 CU00
8 LU00";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}