// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?P<x>\w*?)(?P<y>\d*)$").unwrap();
let string = "df
Ref
0 CU12
1 SE00
2 RLA1234
3 12345
3 RLA456
4 LU00
5 RLA1234MA12
6 RLA1234MA13
7 CU00
8 LU00";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}