using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(http\:\/\/)*w*\.*go+gle\s*.\s*com";
string input = @"google.com
http://google.com
http://www.gooogle.com
gooogle . com";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}