import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "href=\"\\/";
final String string = "<html>\n"
+ " <head>\n"
+ " <title>Hello</title>\n"
+ " </head>\n"
+ " <body>\n"
+ " <p>this is a simple text in html file</p>\n"
+ " <a href=\"https://google.com\">Google</a>\n"
+ " <a href=\"/frontend/login/\">Login</a>\n"
+ " <a href=\"/something/work/\">Something</a>\n"
+ " </body>\n"
+ " </html>";
final String subst = "href=\"\\/more\\/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}