using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"href=""\/([^""]*)";
string substitution = @"href=""\/more\/\1additional";
string input = @"<html>
<head>
<title>Hello</title>
</head>
<body>
<p>this is a simple text in html file</p>
<a href=""https://google.com"">Google</a>
<a href=""/frontend/login/"">Login</a>
<a href=""/something/work/"">Something</a>
</body>
</html>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}