$re = '/((?:[A-Za-z]+-?)*)-in-((?:[A-Za-z]+-?)*)(?:\.[\w]{3,4})?/m';
$str = 'Sammi-Tye-in-Beauty.mp4
Sammi-Tye-in-Classic-Curves.mp4
Sammi-Tye-in-Classy-Erotica.mp4
Sammi-Tye-in-Classy-Erotica';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;