Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
(?<=user id\s*(-|:|is)\s)[A-Z].*"
/
gm
Input 1
1
New
user id - XXX XXX user id- XXX XXX user id XXX XXX user id: XXX XXX user id : XXX XXX user id is XXX XXX