using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=user id\s*(-|:|is)\s)[A-Z].*""";
string input = @"user id - XXX XXX
user id- XXX XXX
user id XXX XXX
user id: XXX XXX
user id : XXX XXX
user id is XXX XXX";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}