package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)-?[\d.]+(?:\,\d+)?;{1,2}\s*EUR`)
var str = `-5,84;;EUR
2.764,90;EUR
-47;;EUR`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}