// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)-?[\d.]+(?:\,\d+)?;{1,2}\s*EUR").unwrap();
let string = "-5,84;;EUR
2.764,90;EUR
-47;;EUR";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}