const regex = /(http(s)?:\/\/|(w){3}).*\.((?:mp4)|).*(youtu(be|.be))?(\.com)?\/?.+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(http(s)?:\\\/\\\/|(w){3}).*\\.((?:mp4)|).*(youtu(be|.be))?(\\.com)?\\\/?.+', 'gm')
const str = ` https://www.example.com/files/video.mp4
http://www.example.com/files/video.mp4
https://example.com/files/video.mp4
http://example.com/files/video.mp4
www.example.com/files/video.mp4
https://www.youtube.com/watch?v=xxxxxx
http://www.youtube.com/watch?v=xxxxxx
https://youtube.com/watch?v=xxxxxx
http://youtube.com/watch?v=xxxxxx
www.youtube.com/watch?v=xxxxxx
https://www.example.com/files/audio.mp3
http://www.youtu.be
www.sweaverd.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}