$re = '/(\([(\d))]{2}\)\s?[(\d)]{4,5}+\-+[(\d)]{4})/m';
$str = '(11)1234-1234';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);