$re = '/\{(\d)}(\()/m';
$str = 'td{2}(i,j),
td{3}(i,j),
td{4}(i,j),';
$subst = "$2$1,";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;