#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)(?(DEFINE)(?<e>(?:.+\n\n|\Z))(?<i>(?:.+\n)))(?:(?:^.{4}|\G.*(?=.{6}$))\K(?=(?&i){5})|(?:^|\G.*(?=..$))\K(?=(?&i){3}(?&e))|(?:^.|\G.*(?=...$))\K(?=(?&i){2}(?&e))|(?:^..|\G.*(?=....$))\K(?=(?&i)(?&e)))..|...\K.+(?=(?:...\n\n|\Z))"
Local $sString = "aaaaaaaaaaaaaaaaaaaa" & @CRLF & _
"aaaaaaaaaaaaaaaaaaaa" & @CRLF & _
"aaaaaaaaaaaaaaaaaaaa" & @CRLF & _
"aaaaaaaaaaaaaaaaaaaa" & @CRLF & _
"aaaaaaaaaaaaaaaaaaaa" & @CRLF & _
"aaaaaaaaaaaaaaaaaaaa" & @CRLF & _
"aaaaaaaaaaaaaaaaaaaa" & @CRLF & _
"aaaaaaaaaaaaaaaaaaaa" & @CRLF & _
"" & @CRLF & _
"sdaffdsdfsdsfaadd" & @CRLF & _
"afdsafdsfssdsfdfs" & @CRLF & _
"afdsfdssdfdssfdsf" & @CRLF & _
"asfddsfafsdfdsdsf" & @CRLF & _
"asfdsdfafdsafasdf" & @CRLF & _
"" & @CRLF & _
"hellohellohellohellohello" & @CRLF & _
"hellohellohellohellohello" & @CRLF & _
"hellohellohellohellohello" & @CRLF & _
"hellohellohellohellohello" & @CRLF & _
"hellohellohellohellohello" & @CRLF & _
"hellohellohellohellohello" & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")