const regex = /(?<=-)0+(?=[1-9]\d*$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=-)0+(?=[1-9]\\d*$)', 'gm')
const str = `020200218-0PSS-001
020200218-0PSS-0010
020200218-0PSS-101`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);