$re = '/^(:?[^0-9\'\-\., _!¡?÷?¿\\\\+=@#$%ˆ&*(){}|~<>;:[\]]+(:?[\'-]|, | |\.|\. |$))+$/m';
$str = 'Jacob Wellman
Wellman, Jacob
Wellman, Jacob Wayne
O\'Shaughnessy, Jake L.
John O\'Shaughnessy-Smith
Kim
TimmyTimmy
Timmy O\'\'Shaughnessy
John O\'Shaughnessy--Smith
K3vin Malone
alert("Hello")
select * from users;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);