#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?'number'(?'float'(?>\d+[\.](?>\d+)?)|(?>(?>\d+)?[\.]\d+))|\d+)(?'exponent'e[+-](?&number))?"
Local $sString = " 2.0 " & @CRLF & _
" .0 " & @CRLF & _
" 3. " & @CRLF & _
" 2e+1 " & @CRLF & _
" 2.0e+1 " & @CRLF & _
" 2.123e+1.2 " & @CRLF & _
"2" & @CRLF & _
"5" & @CRLF & _
" 2 2 4 5 6" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")