using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?'number'(?'float'(?>\d+[\.](?>\d+)?)|(?>(?>\d+)?[\.]\d+))|\d+)(?'exponent'e[+-](?&number))?";
string input = @" 2.0
.0
3.
2e+1
2.0e+1
2.123e+1.2
2
5
2 2 4 5 6
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}