const regex = /(?'number'(?'float'(?>\d+[\.](?>\d+)?)|(?>(?>\d+)?[\.]\d+))|\d+)(?'exponent'e[+-](?&number))?/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?\'number\'(?\'float\'(?>\\d+[\\.](?>\\d+)?)|(?>(?>\\d+)?[\\.]\\d+))|\\d+)(?\'exponent\'e[+-](?&number))?', 'mg')
const str = ` 2.0
.0
3.
2e+1
2.0e+1
2.123e+1.2
2
5
2 2 4 5 6
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}