re = /(?<=father.*?)mother|mother(?=.*?father)|(?<=mother.*?)father|father(?=.*?mother)/m
str = 'Postive matches:
mother a father
father a mother
father a mother a father
mother a father a mother
Non-matches:
just mother
just father
mother then mother
father then father
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end