re = /Security information[\r\n]*Nett sales:[\r\n]+([^\r\n]+)/m
str = 'some
text
goes here
here
Security information
here
and here
Security information
Nett sales:
15333.40
text after this too
here
Nett sales:
here
Security information
Nett sales:1343556
here too 1234 88475 page1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end