use strict;
my $str = 'This 9 is 8 a 77 6 test';
my $regex = qr/^(\D*\d+\D*)\d+/mp;
my $subst = '$1hello';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";