// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)Android \d+; ([^;]+) Build").unwrap();
let string = "Android 13; SM-A515F Build/
Linux; Android 10; LM-K510 Build/";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}