Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
^(?=.*?[A-Z])(?=.*?[a-z])(?=.*?[0-9])|[^\w\s].{8,20}$
/
gm
Input 1
1
New