re = /^[a-zA-Z]:(\\[^\:\\]+)\\[a-z-A-Z]ystem32\\[a-z-A-Z]md.exe/m
str = 'c:\\Windows\\system32\\Cmd.exe'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end