# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:https?:\/\/)?([-\w.]+\.[\w]+){1}(\/[\/\d\w\.\-\?\+\&\#\=\~]*)?$"
test_str = "https://www.asd.google.com/search?q=some+text¶m=3#dfsdf"
subst = "Domein: $1\\nURI: $2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.