import Foundation
let pattern = ##"^(?:https?:\/\/)?([-\w.]+\.[\w]+){1}(\/[\/\d\w\.\-\?\+\&\#\=\~]*)?$"##
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = ##"https://www.asd.google.com/search?q=some+text¶m=3#dfsdf"##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"Domein: $1\nURI: $2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)