// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([A-Za-z]{2})(.*?)([A-Za-z][0-9]?)?$").unwrap();
let string = "AA123123A1
AA123123A
AA123123123";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}