use strict;
my $str = 'This jus might be the result either of traditional and inveterate custom <hi rend="italic">(jus moribus constitutum</hi> or of statute <hi rend="italic">(lex).@@3As to the customs</hi>, it can well be believed that at the outset they were far from uniform; that not only the customs of the three original tribes.';
my $regex = qr/(<hi\s*rend="\w*">)([\w\s()]*[^<])(@{2,3}\d{1,2}?)([\w\s()]*[^<])?(<\/hi>)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}