$re = '/ *-.*/';
$str = 'THIS IS A TEST - 10-01-2010 - HELLO WORLD (OKAY)!!
THIS IS A TEST-10-01-2010 - HELLO WORLD (OKAY)!!
THIS IS A TEST - - - - 10-01-2010 - HELLO WORLD (OKAY)!!
THIS IS A TEST';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;