import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "%%%\\[emoticon.*]%%%";
final String string = "%%%[emoticon name|https://example.org/name.jpg|67|45|/emoticon_report/name/]%%%\n"
+ "Michel\n"
+ "%%%[emoticon name|https://blabla/]%%%\n";
final String subst = "Emoticon";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}