use strict;
my $str = '%%%[emoticon name|https://example.org/name.jpg|67|45|/emoticon_report/name/]%%%
Michel
%%%[emoticon name|https://blabla/]%%%
';
my $regex = qr/%%%\[emoticon.*]%%%/mp;
my $subst = 'Emoticon';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";