$re = '/%%%\[emoticon.*]%%%/m';
$str = '%%%[emoticon name|https://example.org/name.jpg|67|45|/emoticon_report/name/]%%%
Michel
%%%[emoticon name|https://blabla/]%%%
';
$subst = "Emoticon";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;