import Foundation
let pattern = #"%%%\[emoticon.*]%%%"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
%%%[emoticon name|https://example.org/name.jpg|67|45|/emoticon_report/name/]%%%
Michel
%%%[emoticon name|https://blabla/]%%%
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"Emoticon"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)