$re = '/(.*)(\()(.*)(\))/m';
$str = 'rob(something)
bob (else ) here
john(fran
key ) and (this)
edward ( bob ) john
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);