#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?s)data.+?run;"
Local $sString = "data xxxxx;" & @CRLF & _
"yyyyy" & @CRLF & _
"xxxxxx" & @CRLF & _
"run;" & @CRLF & _
"" & @CRLF & _
"fffff" & @CRLF & _
"yyyyy" & @CRLF & _
"" & @CRLF & _
"data fff;" & @CRLF & _
"fffff" & @CRLF & _
"run;"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")