package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?s)data.+?run;`)
var str = `data xxxxx;
yyyyy
xxxxxx
run;
fffff
yyyyy
data fff;
fffff
run;`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}