re = /(?s)data.+?run;/m
str = 'data xxxxx;
yyyyy
xxxxxx
run;
fffff
yyyyy
data fff;
fffff
run;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end