$re = '/\d{10}(?=\s)|(?<=")\d{10}(?=")/m';
$str = '23436571545994641 INFO: ...
and
\'{"deliveryDate":"1545994641","error"..."}\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);