package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\w*_abcd)\s*(?: (abcd_\w*);?)+`)
var str = ` thing: random1_abcd
abcd_n1p3; abcd_n2p1
"random2_abcd" does not exist.
thing: random3_abcd
abcd_n1p1; abcd_n2p3
thing: random4_abcd
abcd_n1p3; abcd_n3p1; abcd_n2p7
thing: random5_abcd
abcd_n4p2; abcd_n3p3; abcd_n6p7; abcd_n1p6
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}