use strict;
my $str = 'iploc.eset.com
versioncheck.eset.com
edf.eset.com
trace.eset.com
ipm.eset.com
banner.eset.com
pki.eset.com
proxy.eset.com
proxy-detection.eset.com
h1-weblb01-v.eset.com
h3-weblb01-v.eset.com';
my $regex = qr/^(?:banner|ipm|trace|edf|versioncheck|iploc|p(?:ki|roxy(?:-detection)?)|h[1,3]-weblb01-v)\.eset\.com$/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}