const regex = /(numberPinyin":\s*".*)(v)(.*)"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(numberPinyin":\\s*".*)(v)(.*)"', 'gm')
const str = `['{"russian": "женщина", "english": "woman, v","numberPinyin": "nv3","typeOfChar":"character","typeOfTranslating":"original"}',
'{"chinese": "弯竖左钩", "russian": "вогнутая с крюком влево", "english": "concave with left hook","numberPinyin": "eav","typeOfChar":"stroke","typeOfTranslating":"byStrokes"}',
'{"chinese": "弯竖右钩", "russian": "вогнутая с крюком вправо", "english": "concave with right hook","numberPinyin": "vm2","typeOfChar":"stroke","typeOfTranslating":"byStrokes"}']`;
const subst = `\1ü\3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);