import re
regex = re.compile(r"(numberPinyin\":\s*\".*)(v)(.*)\"", flags=re.MULTILINE)
test_str = ("['{\"russian\": \"женщина\", \"english\": \"woman, v\",\"numberPinyin\": \"nv3\",\"typeOfChar\":\"character\",\"typeOfTranslating\":\"original\"}',\n"
"'{\"chinese\": \"弯竖左钩\", \"russian\": \"вогнутая с крюком влево\", \"english\": \"concave with left hook\",\"numberPinyin\": \"eav\",\"typeOfChar\":\"stroke\",\"typeOfTranslating\":\"byStrokes\"}',\n"
"'{\"chinese\": \"弯竖右钩\", \"russian\": \"вогнутая с крюком вправо\", \"english\": \"concave with right hook\",\"numberPinyin\": \"vm2\",\"typeOfChar\":\"stroke\",\"typeOfTranslating\":\"byStrokes\"}']")
subst = "\\1ü\\3"
result = regex.sub(subst, test_str)
if result:
print(result)