re = /(numberPinyin":\s*".*)(v)(.*)"/m
str = '[\'{"russian": "женщина", "english": "woman, v","numberPinyin": "nv3","typeOfChar":"character","typeOfTranslating":"original"}\',
\'{"chinese": "弯竖左钩", "russian": "вогнутая с крюком влево", "english": "concave with left hook","numberPinyin": "eav","typeOfChar":"stroke","typeOfTranslating":"byStrokes"}\',
\'{"chinese": "弯竖右钩", "russian": "вогнутая с крюком вправо", "english": "concave with right hook","numberPinyin": "vm2","typeOfChar":"stroke","typeOfTranslating":"byStrokes"}\']'
subst = '\\1ü\\3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result