package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d+,\d+`)
var str = `84,96 <-- good
84.96 <-- bad`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}