# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^http:..|^https:..|\/.*"
test_str = ("https://www.asd.google.com\n"
"https://www.google.net\n"
"https://www.google.co.nz\n"
"https://google.com\n"
"https://www.google.com/api?=login/someshit\n"
"https://www.google.com/ads/getmeadrink/api?0284230284782487871837871301-0/\n"
"www.google.com/ads/v1/api?139305u30u130130/quote/\n")
matches = re.finditer(regex, test_str, re.IGNORECASE | re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.